Data merge with lllustrator

Why data merge?

If you want to create a number of documents with the same layout but different
content, it may be easier and less time-consuming to create a template in Illustrator
and then “fill” in the placeholders with data from another source. A good example
of this would be if you were doing 100 name tags, and each name tag had the same
layout, with a background image, logo and border, but a different name and photo.
You would create the template with the background image, border and a placeholder
name and image. Then you would data merge in the names and images to create 100
individualised name tags.

[llustrator and InDesign both data merge documents. InDesign will data merge
into one document, whereas Illustrator is a little more complex and will data merge
individual datasets and you then have to batch process the result into separate
documents which are exported either as PDF or as Illustrator files. This is because
Illustrator does not do “multipage” documents like InDesign does. Both processes
have their advantages and disadvantages.

I will take you through both processes and you can choose which software you prefer
and which suits you best. If you want separate files for each output, then Illustrator
will be best. If you want one file that contains all the documents, then InDesign is
best.

Skills you should have before starting this:

+ Be confident using a spreadsheet to enter information (no formulae required)
+ Be able to save a spreadsheet as a .csv file

 Be able to work confidently with text and images in Illustrator

+ Be able to create and apply paragraph styles in Illustrator

[llustrator data merge:

These are the steps that I will take you through:

1. Create template

2. Set up source file and save as .csv
3. Import the source file

4. Bind each variable to an object

5. Preview each dataset

6. Export the files using actions

Eeate a template

You need a template for your design before you start. The template will have the
elements of your final document that are both constant (will stay the same across all
documents) and dynamic (will change in each document).

Each element of your document that is dynamic will need to have a corresponding
element in the data source. You need to make sure that when you are creating your
template, you are thinking about the information that is going to go into the final
document, and making sure that you take note of what needs to go into your data
source document to populate your final document.

A template in this instance is just a new document.
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my students would find this text-based explanation hard to follow. Would it be possible to provide video or animation of this process to make it easier for students with lower literacy or attention span?

Helen Chileshe
screencasts are here.



https://indd.adobe.com/view/8c88d1fd-add7-4c71-bda2-b95eee50c8bc
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Go to File > New and click on Create New. The following Dialog box will appear.

L) New Document

(© Recent

Untitled-1

210 mm

297mm. |

2 omm 2 omm

C omm > omm

CMYK Color

Create

Choose Print from the selection at the top, and then enter your dimensions, or
choose from the preset A4, A3 etc.

Check that your document is CMYK colour mode. If it isn’t, click on Advanced,
and choose CMYK from the dropdown menu. Then select Create.

Your students will go through the design process and get to a final design from
which they will create a template (or their final design will become their template if
their design process is digital). Images will be place-holders, and textboxes will be set
up with paragraph styles and dummy text.

Anything that is constant on each document can be created and put into the
template.

For example, on the template below, the “Contact Us” is the same on every
document, and the brown and black panels are the same on every document. The
rest of the text is dummy text, with paragraph styles created and applied.

Once you have created your document, go to File > Save As > Template

[llustrator template example:

Gontact Us:

Lorem ipsum dolor sit amet, consectetuer
nummy nibh
eet dolore magna ali

Lorem ipsum dolor sit amet,

my nibh euismod tincidunt ut lacreet
dolore magnper

my nibh euismod tincidunt ut lacreet
dolorenim veniam, quis nostrud exerci
tation ullamcorper
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2. Source file

The source file contains the data and images that will go into your documents. For
the purpose of this example, I am creating a spreadsheet, and saving it as a .csv file.

To create a .csv file, just make a spreadsheet (Excel or Googlesheetss will both work)
and Save as (Excel) or Download (Googlesheets) as .csv (comma separated values).
Do not choose MS-Dos or Windows Comma Separated if you are on a Mac.

Your spreadsheet needs to have headings in cells across the top that will correspond
to any fields/placeholders in your template.

For example, if you have three text boxes that need text filled in your template, you
will have three columns in your spreadsheet, appropriately named according to the
text they contain. eg “companyName”, “companyAddress’, “smallBlurb”

For any images, you need to have the full filepath typed into the cell. The filepath is
the place or location of the image file on your computer. It tells Illustrator where to
find the image on your computer, what folder it is saved in, where it is located and
what it is called.

Image columns must start with the @ symbol eg @mainImage.

[lustrator will show you what the filepath is for your images.(see screenshot below)

hobbit2.jpg

hobbitl.jpg

S @

Name: hobbitl.jpg
Format: JPG (Linked File)
Color Space: RGB (Adobe RGB (1998))

Location:

Go to File > Place and place an image from the same folder that you are keeping
all your assets in. Then go to Window > Links and it will show you the links panel.
Click on the down arrow underneath the bottom image to open up the dialog box
under the list of images that are linked.

Mlustrator will show you the full file path, and you will need to type it into the
spreadsheet.

Don’t worry about getting all of your different data for every document to look
good in the template before putting it into the spreadsheet. Once you have the

data put into the data source, and you create the data merge, you can preview each
dataset individually before you actually make the final merge. This final step means
that you can go back and make any changes to your layout and information before
committing to the data merge and exporting your files. You can re-link your data
source at any time, which means that you can make changes to the amount of text
in there, save it and re-link, then do the data merge again and preview the data sets
before committing to the final data merge and exporting the files.

The Location shows the full filepath that you need. You may need to drag out the box
to see the entire filepath. You need to type this filepath into the cell in the source file.
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detting up your source file:

Each heading in your spreadsheet corresponds to a piece of information (text or
image) that will be in each document you are producing. The headings in your
spreadsheet must have no spaces. For example, for “mainimage” you cannot have
“main image”. It needs to be “mainimage”, “mainImage”, “main_image” etc. Any
spaces in the heading names will result in the import failing in both InDesign and

Ilustrator.

If you are using images, then you need to begin with an @ symbol in your heading.
Some spreadsheet applications do not like this, so you need to put a single quote in
front of the @. So, mainimage becomes ‘@main image. The @ symbol tells Illustrator
that it is a graphic. (note the single quote in the formula bar. It doesn’t show in the
cell itself.)

fx '@mainimage

F G

category  |@mainimage
Waitomo Ad\/Users/helen/Deskt

Put the information that you want for each document into the spreadsheet. Each row
corresponds with a separate document. So, if you have 12 documents that need to be

created, you will have 12 rows. For the sake of this example, I will call each document
a record.

Do not have any empty columns in your headings. If you have an empty heading
column, then Illustrator will tell you that your csv file “is not valid” when you try to
import it. It is OK to have empty columns in the records. Eg if you had two address
lines for one record, but only one address line for another, have two address lines in
the headings “Address1” and “Address2”. Then in the record with only one address
line, you can leave the second address column empty.

Once you have populated your spreadsheet with the data you need, save it as a .csv
file.

Neither Illustrator nor InDesign like it if the spreadsheet is open when you do the
data merge, so make sure that you close the spreadsheet once it is completed and
saved as a .csv file.

For this example, I only created two records, so my csv file had only two rows under
each heading.
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Now, you need to make sure that your template and the source file will “marry” up
together.

company name

subtitle paragraph contact details main image

Gontact Us:

Lorem ipsum dolor sit amet, | Title

my nibh euismod tincidunt ut laoreet
dolore magnper category
my nibh euismod tincidunt ut lareet initsiadaiie
dolorenim veniam, quis nostrud exerci

tation ullamcorper

D E F G H
1 Title i i i i -apl category @mainimage @smallimagel
2 Waitomo Ca: Discover a pl Waitomo Adventures Call us +64 7 878 The Waitomo Ca' Waitomo Adver /Users/helen/I /Users/helen/Deskt]
3 |Hobbiton In the heart « Hobbiton Tours 501 Buckland Roz In 1998, Sir Peter Family Day Trip /Users/helen/I /Users/helen/Deskd]
a

Check that each element on your template that is dynamic (will change with each
document) has a corresponding column in the spreadsheet).

3. Importing the source file:
1. Open the variables panel Window > Variables.

2. Click on Import and select your .csv file. The cell headings that you used in your
source document should appear in the dialog box.

Variables

Data Set v 4 )
Variables Objects

Title

infowhite

companyname

contactdetails

subtitleparagraph

Learn More

category
mainimage
smallimagel

smallpanel

=
T
T
T
T
T
T
d
d
Wd
¥

largepanel
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4. Binding objects to variables

Now you need to bind the variables to the object on the template.

« Select the image or text box on the template
o Select the name of the variable on the panel
« Click on the “make linked file dynamic” icon at the bottom of the panel.

Once you have bound a variable to an object, the name of the object it is bound to
will appear in the Objects column.

Variables
Gontact Us:
3 Data Set: v 4 )
T Variables Objects.
Title Lorem ipsu...
infowhite my nibh eui...
contactdetails Lorem ipsu...

subtitleparagraph Lorem ipsu...

mainimage vic falls hall.tif

r
ar
T
T
T  category my nibh eui...
d
d

+mallimage1 <Linked File>

Lorem ipsum dolor sit amet,

my nibh euismod tincidunt ut laoreet
dolore magnper

my nibh euismod tincidunt ut laoreet
dolorenim veniam, quis nostrud exerci
tation ullamcorper

Do this for each element in the document that needs to be dynamic. When you select
text, the icon at the bottom of the panel will stay the same, but the wording will
change to “make text dynamic”.

9. Preview each dataset

Once you have completed all of the dynamic items, you can click on the “data set”
down arrow at the top of the variables panel (to the right of the camera icon), and
scroll through each version of the document.

Each dataset will give you a different version of the document, according to the data
that is in the spreadsheet source file.

Check that each dataset looks correct. You may need to adjust some of your text
settings, or increase the size of text boxes if text doesn’t fit.

Variables

Data Set

Variables

Title

infowhite
companyname

contactdetails

6. Batch process your datasets

Once you're happy with how your datasets are looking, you need to batch process
your file to save each document individually.

[lustrator will save the files as individual files (either .ai or .pdf files).

Create a new folder where you want the files saved and name it appropriately.
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Create an action to save your file:

Go to Window > Actions, and in the submenu in the top right corner choose
New Action.

ctions New Action...
New Set...
Duplicate
Delete
Play

Start Recording
Record Again...
Insert Menu ftem...
Insert Stop...
Insert Select Path
Select Object...

Action Options...
Playback Options...

Clear Actions
Reset Actions

« Give your new action a name, such as “Savedatamerge”.

o Start recording.

+ Go to File > Save As and give your file a name.

o Then press the stop record button. You will see your action appear in the list
of actions.

« Select your action by clicking on it.

« With your action selected (it will be a pale blue colour), go to the submenu
again, and choose Batch.

You will get a new dialog box.

You should make sure that you select the following (circled in red):

o Select the action that you created in the Action dropdown menu.

o Select Data Sets as your source.

» Choose your new folder in the destination option

« Choose any of the three options on the right for your filename. This will give
each document a unique name. If you don’t choose one of these options, then
you will end up with just one file, as it will overwrite the file with the same
filename each time it processes the data set.

o Press OK

Batch

Play
Set: | Default Actions

Action: saveDatamerge

source: Data Sets ~

@ No options available

Destination: None =

(_Choose... ) /Users/...merge/trialdatamerae File lvame

Override Action “Save” Commands © File + Number

/Users/...merge/trialdatamerge O File + Data Set N3

@, "
Override Action “Export” Commands ( Data Set Name

Errors: Stop for Errors ~

Go to your folder to check that you have the correct number of files. If you had 20
records in your spreadsheet, you should now have 20 different files, each with unique
data in it for your outcome.
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Screencasts:
Setting up the data source



Data merge with lllustrator

Previewing data sets

Batch processing to export and save
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